Issue with loading maps

Incident Report for OptimoRoute

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 20:25 UTC

Investigating

Since 6:30 pm UTC today, we have been experiencing issues with loading maps, caused by the instability of our 3rd party provider. We're currently working on the solution.
Posted Jun 12, 2025 - 19:32 UTC
This incident affected: OptimoRoute Application.